When you upgrade Lightroom from version 1 to version 2, you need to upgrade your catalog (database file) also.

You only need to do this once. If you know you’ve already completed an upgrade from v1 to v2, STOP!! Lightroom is trying to load the wrong catalog.

Use the options on the dialog box to find and load your most recent catalog.

Get Photography tips, techniques and
tutorials FREE to your inbox

We value your privacy and will never share your details with anyone.

Almost there... Check your inbox to confirm.

Pin It on Pinterest

Share This